现在的位置: 首页 > 综合 > 正文

hdu 1496 Equations

2018年01月21日 ⁄ 综合 ⁄ 共 1604字 ⁄ 字号 评论关闭

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5526    Accepted Submission(s): 2193

Problem Description
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
1 2 3 -4 1 1 1 1
 

Sample Output
39088 0
 
/*题解:
hash问题
*/
// =====================================================================================
// 
//       Filename:  Equations.cpp
//    Description:  Equations
//      Algorithm:  hash+二重循环
//         Status: 	RunTime:187ms 	RunMemory:8044K 
//        Version:  Dev-C++ 4.9.9.1 
//        Created:  2014/10/9 22:32 
//       Revision:  none
//       Compiler:  G++
//         Author:  Tip of the finger melody, 1466989448@qq.com
//        Company:  none
//
// =====================================================================================

#include<cstdio>
#include<cstring>
int p[10002],hash[2000002];
void solve()
{
	int a,b,c,d,i,j,sum;
	for(i=1; i<=100; i++)
		p[i] = i*i;
	while(scanf("%d %d %d %d",&a,&b,&c,&d)!=EOF)
	{
		if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
		{
			printf("0\n");
			continue;
		}
		memset(hash,0,sizeof(hash));
		for(i=1; i<=100; i++)
			for(j=1; j<=100; j++)
				hash[p[i]*a+p[j]*b+1000000]++;
		for(i=1,sum=0; i<=100; i++)
			for(j=1; j<=100; j++)
				sum += hash[-(p[i]*c+p[j]*d)+1000000];
		printf("%d\n",sum*16);
	}
}
				

int main()
{
	solve();
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.