现在的位置: 首页 > 综合 > 正文

NYOJ 221 Tree

2018年01月21日 ⁄ 综合 ⁄ 共 2827字 ⁄ 字号 评论关闭

Tree

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with
capital letters in the nodes. 
This is an example of one of her creations: 

                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB

/*题解: 
①先根据先序遍历和中序遍历建立二叉树,②后序遍历二叉树
                                    ——参考自《编程之美》p48
*/


  前序遍历:先访问根节点,然后以前序访问左子树,右子树。
  中序遍历:左子树,当前节点,右子树。
根据前序和中序遍历的特点,可以发现如下规律:
前序遍历的每个节点,都是当前子树的根节点。同时,以对应的节点为边界,
就会把中序遍历的结果分为左子树和右子树。例如:
前序:a b d c e f 
'a'是根节点
中序:d b a e c f
'a'是根节点,把字符串分成左右两个子树
'a'是前序遍历节点的第一个元素,可以看出,它把中序遍历的结果分成'db'和'ecf'两部分。如图:
 
这就是'a'的左子树和右子树的遍历结果。
如果能够找到前序遍历中对应的左子树和右子树,就可以把'a'作为当前的根节点,
然后依次递归下去,这样就能够依次恢复左子树和右子树的遍历结果。 


后序遍历二叉树的操作定义为:
若二叉树为空,则空操作;否则
(1)后序遍历左子树;
(2)后序遍历右子树;
(3)访问根结点。
伪代码: 

void PostOrder(T)//T是树根
{
if(T为空)return;
PostOrder(T的左子树);
PostOrder(T的右子树);
访问T的元素;
}

AC代码:

#include<iostream>
#include<cstring>
#include<malloc.h>
using namespace std;
typedef struct Node
{
	Node * lchild,*rchild;
	char value;
}Tree;
void ReBuild(char* PreOrder,char* InOrder,int TreeLen,Tree** root)
{
	Tree *p;
	char *LeftEnd;
	if(PreOrder == NULL||InOrder == NULL||root == NULL)//检查边界条件 
	{
		return;
	}	
	p = (Tree *)malloc(sizeof(Tree));//获得前序遍历的第一个节点 
	p->value=*PreOrder;
	p->lchild = p->rchild = NULL;
	*root = p;
	if(TreeLen==1) return;//一个节点直接结束 
	LeftEnd=InOrder;//LeftEnd得到先序遍历根节点的值
	while(*LeftEnd!=*PreOrder)//在中序遍历中查找该点的位置
	{
		LeftEnd++;
	}	
	//寻找左子树长度
	int LeftLen = 0;
	LeftLen = (int)(LeftEnd - InOrder);
	//寻找右子树长度 
	int RightLen = 0;
	RightLen = TreeLen-LeftLen-1;
	//重建左子树,递归 
	if(LeftLen>0)
		ReBuild(PreOrder+1,InOrder,LeftLen,&(p->lchild)); 
	//重建右子树,递归	
	if(RightLen>0)
		ReBuild(PreOrder+LeftLen+1,InOrder+LeftLen+1,RightLen,&(p->rchild));
}

void PostOrder(Tree *p)//二叉树建完后进行后序遍历。 
{
	if(p!=NULL)
	{
		PostOrder(p->lchild);
		PostOrder(p->rchild);
		cout<<p->value;
	}
}
int main()
{
	char a[110],b[110];
	Tree *p;
	while(cin>>a>>b)
	{
		int len = strlen(a);
		ReBuild(a,b,len,&p);
		PostOrder(p);
		cout<<endl;
	}
	return 0;
} 

抱歉!评论已关闭.