现在的位置: 首页 > 综合 > 正文

hdu 218 Dinner

2018年01月21日 ⁄ 综合 ⁄ 共 1344字 ⁄ 字号 评论关闭

Dinner

时间限制:100 ms  |  内存限制:65535 KB
难度:1
描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is
not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box,
which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl
提示
The tableware only contains: bowl, knife, fork and chopsticks.
来源

辽宁省10年省赛

/*题解:
大水题,竟然是辽宁省10年省赛题,- -! 
题目大意是:输入几个字符串,将是餐具字符串输出( bowl, knife, fork,chopsticks是餐具) 
*/

#include<cstdio>
#include<cstring>
int main()
{
	int n,i,k;
	char str[10],s[1010][10];
	while(scanf("%d",&n)!=EOF)
	{
		k=0;
		memset(s,0,sizeof(s));
		for(i=0; i<n; i++)
		{
			scanf("%s",str);
			if(strcmp(str,"bowl")==0||strcmp(str,"knife")==0||strcmp(str,"fork")==0||strcmp(str,"chopsticks")==0)
			{
				strcat(s[k++],str);
			}
		}
		printf("%s",s[0]);
		for(i=1; i<k; i++)
			printf(" %s",s[i]);
		printf("\n");
	}
}

抱歉!评论已关闭.