现在的位置: 首页 > 综合 > 正文

对称排序

2018年01月21日 ⁄ 综合 ⁄ 共 2195字 ⁄ 字号 评论关闭

题目来源:NYOJ

对称排序

时间限制:1000 ms  |  内存限制:65535 KB
难度:1
描述
In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as
the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names
belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc. 
输入
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings,
one per line, NOT SORTED. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long. 
输出
For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.
If length of two strings is equal,arrange them as the original order.(HINT: StableSort recommanded)
样例输入
7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0
样例输出
SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill

题目大意:先将给定的字符串安长度从小到大排序(注意:如果长度相同,则按输入的顺序排。例如:输入数据有abc ,和 bcd ,则排序后这两个数据的位置应该为  先abc,再bcd),排序后奇数位置的安顺序输出,偶数位置的倒序输出,如有7个字符串,则排序后输出顺序为 1 3 5 7 6 4 2;

下面给出代码:

/*代码使用快速排序,由于快排的不稳定性,该代码中加入了稳定因素 location*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct str{
	char s[20];//存储每个字符串
	int len;//字符串长度
	int location;//字符串位置(稳定因素)
}st[30];
int com(const void *a,const void *b)
{
	struct str *aa=(struct str *)a;
	struct str *bb=(struct str *)b;
	if(aa->len==bb->len)//如果长度相同,按输入顺序排列
		return aa -> location - bb -> location;
	else
		return aa -> len - bb -> len;
}
int main()
{
	int i,j,n,count = 1;
	while(scanf("%d",&n)&&n!=0){
		for(i = 1;i <= n; i ++){//读入并设置相关参数
			scanf("%s",st[i].s);
			st[i].len = strlen(st[i].s);
			st[i].location = i;
		}
		qsort(&st[1],n,sizeof(st[0]),com);//排序
		/*//测试排序结果
		for(i = 1; i <= n;i ++)
			printf("%s\n",st[i].s);*/
		printf("SET %d\n",count);
		count ++;
		//*分情况打印*//
		for(i=1;i<=n;i++){
			if(i%2!=0)
				printf("%s\n",st[i].s);
		}
		for(i=n;i>=1;i--){
			if(i%2==0)
				printf("%s\n",st[i].s);
		}
	}
	return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.