现在的位置: 首页 > 综合 > 正文

hdu1051(Wooden Sticks 贪心)

2018年02月22日 ⁄ 综合 ⁄ 共 1908字 ⁄ 字号 评论关闭
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to
prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden
sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one
or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1

Sample Output
2
1
3

 

#include<stdio.h>
struct node1
{
    int x,y,flog;
};
int main()
{
    int t,i,j,n,tim;
    struct node1 f[5005],tm;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
           {
               scanf("%d%d",&f[i].x,&f[i].y);
               f[i].flog=1;//1表示没有访问过,0表示访问过了
           }
            for(i=0;i<n;i++)//先按x从小到大排
            for(j=i+1;j<n;j++)
            if(f[i].x>f[j].x)
            {
                tm=f[i];f[i]=f[j];f[j]=tm;
            }
            else if(f[i].x==f[j].x&&f[i].y>f[j].y)//x相等,就看y,从小到大排
            {
                tm=f[i];f[i]=f[j];f[j]=tm;
            }
           tim=0;
            for(i=0;i<n;i++)
            if(f[i].flog)
            {
                tm=f[i];  tim++;
                for(j=i+1;j<n;j++)
                if(f[j].flog)
                if(tm.y<=f[j].y)
                {
                    tm=f[j];f[j].flog=0;
                    //printf("%d %dd ",j,tim);
                }
            }
            printf("%d\n",tim);
    }
}

 

抱歉!评论已关闭.