现在的位置: 首页 > 综合 > 正文

hdu2192(MagicBuilding 贪心)

2018年02月22日 ⁄ 综合 ⁄ 共 1316字 ⁄ 字号 评论关闭
Problem Description
As the increase of population, the living space for people is becoming smaller and smaller. In MagicStar the problem is much worse. Dr. Mathematica is trying to save land by clustering buildings and then we call the set of buildings
MagicBuilding. Now we can treat the buildings as a square of size d, and the height doesn't matter. Buildings of d1,d2,d3....dn can be clustered into one MagicBuilding if they satisfy di != dj(i != j).

Given a series of buildings size , you need to calculate the minimal numbers of MagicBuildings that can be made. Note that one building can also be considered as a MagicBuilding.
Suppose there are five buildings : 1, 2, 2, 3, 3. We make three MagicBuildings (1,3), (2,3), (2) .And we can also make two MagicBuilding :(1,2,3), (2,3). There is at least two MagicBuildings obviously.

Input
The first line of the input is a single number t, indicating the number of test cases.
Each test case starts by n (1≤n≤10^4) in a line indicating the number of buildings. Next n positive numbers (less than 2^31) will be the size of the buildings.

Output
For each test case , output a number perline, meaning the minimal number of the MagicBuilding that can be made.

Sample Input
2 1 2 5 1 2 2 3 3

Sample Output
1
2

 

题目意思是:求出最少要建的栋数(一栋可以有很多房);

思路:算出最多出现的次数房的个数.

 

#include<stdio.h>
int main()
{
    int t,n,a[10005]e,i,j,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        sum=0;
        for(i=0;i<n;i++)
        {
            e=1;
            for(j=i+1;j<n;j++)
            if(a[i]==a[j])
            {
               e++;
            }
            if(e>sum)//这房出现的次数
            sum=e;
           
        }
        printf("%d\n",sum);
    }
}

 

抱歉!评论已关闭.