现在的位置: 首页 > 综合 > 正文

ZOJ Talented Chef

2018年02月22日 ⁄ 综合 ⁄ 共 1181字 ⁄ 字号 评论关闭

As we all know, Coach Gao is a talented chef, because he is able to cook
M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course,
Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare
N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking,
Coach Gao can choose at most M different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer
T
indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <=
N
, M <= 40000). The second line contains N integers
Ai
(1 <= Ai <= 40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
    int t,n,m,sum,a,max,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        sum=0; max=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            if(max<a) max=a;
            sum+=a;
        }
        if(n<=m)
        {
            printf("%d\n",max);
        }
        else
        {
            k=sum/m;
            if(sum%m)k++;
            if(k<max)k=max;
            printf("%d\n",k);
        }
    }
}

抱歉!评论已关闭.