现在的位置: 首页 > 综合 > 正文

ZOJ Ternary Calculation

2018年02月22日 ⁄ 综合 ⁄ 共 1411字 ⁄ 字号 评论关闭

Complete the ternary calculation.

Input

There are multiple test cases. The first line of input contains an integer
T
indicating the number of test cases. For each test case:

There is a string in the form of "number1operatoranumber2operatorbnumber3". Each operator will be one of {'+', '-' , '*', '/', '%'}, and each number will be an integer in [1, 1000].

Output

For each test case, output the answer.

Sample Input

5
1 + 2 * 3
1 - 8 / 3
1 + 2 - 3
7 * 8 / 5
5 - 8 % 3

Sample Output

7
-1
0
11
3

Note

The calculation "A % B" means taking the remainder of
A
divided by B, and "A / B" means taking the quotient. 

#include<stdio.h>
int main()
{
    char o[3];
    int t,sum,a[4];
    scanf("%d",&t);getchar();
    while(t--)
    {
        scanf("%d %c %d %c %d",&a[0],&o[0],&a[1],&o[1],&a[2]);
        if((o[0]=='-'||o[0]=='+')&&(o[1]=='*'||o[1]=='/'||o[1]=='%'))
        {
            int b;
            if(o[1]=='*')b=a[1]*a[2];
            if(o[1]=='/')b=a[1]/a[2];
            if(o[1]=='%')b=a[1]%a[2];
            if(o[0]=='+')sum=a[0]+b;
            if(o[0]=='-')sum=a[0]-b;
        }
        else if((o[1]=='-'||o[1]=='+')&&(o[0]=='*'||o[0]=='/'||o[0]=='%'))
        {
            int b;
            if(o[0]=='*')b=a[0]*a[1];
            if(o[0]=='/')b=a[0]/a[1];
            if(o[0]=='%')b=a[0]%a[1];
            if(o[1]=='+')sum=a[2]+b;
            if(o[1]=='-')sum=b-a[2];
        }
        else if((o[0]=='*'||o[0]=='/'||o[0]=='%')&&(o[1]=='*'||o[1]=='/'||o[1]=='%'))
        {
            int b;
            if(o[0]=='*')b=a[0]*a[1];
            if(o[0]=='/')b=a[0]/a[1];
            if(o[0]=='%')b=a[0]%a[1];

            if(o[1]=='*')sum=b*a[2];
            if(o[1]=='/')sum=b/a[2];
            if(o[1]=='%')sum=b%a[2];
        }
        else if((o[0]=='-'||o[0]=='+')&&(o[1]=='-'||o[1]=='+'))
        {
            if(o[0]=='+')sum=a[0]+a[1];
            if(o[0]=='-')sum=a[0]-a[1];
            if(o[1]=='+')sum+=a[2];
            if(o[1]=='-')sum-=a[2];
        }
        printf("%d\n",sum);
    }
}
【上篇】
【下篇】

抱歉!评论已关闭.