现在的位置: 首页 > 综合 > 正文

hdu1907John (尼姆博弈,存在一种特殊情况全为1时)

2018年02月22日 ⁄ 综合 ⁄ 共 1230字 ⁄ 字号 评论关闭
Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on.
Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M
colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input
2 3 3 5 1 1 1

Sample Output
John Brother
#include<stdio.h>
int main()
{
    int t,n,c,a[105],k;
    scanf("%d",&t);
    while(t--)
    {
        k=0;c=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]); c^=a[i];
            if(a[i]>1) k=1;
        }
        //当c为0时,也就是先手是输家
       if(c&&k||!k&&n%2==0)
        printf("John\n");
        else printf("Brother\n");
    }
}

抱歉!评论已关闭.