现在的位置: 首页 > 综合 > 正文

hdu1258 Sum It Up (DFS)

2018年02月22日 ⁄ 综合 ⁄ 共 2523字 ⁄ 字号 评论关闭
Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2,
and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise,
t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order,
and there may be repetitions.

Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order.
A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums
with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0

Sample Output
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;

int a[15],vist[15],b[1000][15],len[1000],bb[15];
int k,su,n,sum,m,flog;

bool cmp(int a,int b)
{
    return a>b;
}
int findIn_b(int bb[],int m)//是不 是在b数组里面出现,有则表明不用重复输出同一组
{
    int i,j;
    for(i=0;i<k;i++)
    if(m==len[i])
    {
        for(j=0;j<len[i];j++)
            if(bb[j]!=b[i][j])
            break;
        if(j==len[i])
            return 1;
    }
    return 0;
}

void prin_bb(int bb[],int m)//输出
{
    int i;
    flog=1;//记录有没有输出过
    printf("%d",bb[0]);
    b[k][len[k]++]=bb[0];//装入,为下一次做对比
    for(i=1;i<m;i++)
    {
        printf("+%d",bb[i]);
        b[k][len[k]++]=bb[i];
    }
    k++;
    printf("\n");
}

void DFS(int x)
{
    int i;
        su+=a[x];
        bb[m++]=a[x];
        vist[x]=1;
    if(!findIn_b(bb,m)&&su==sum)
        prin_bb(bb,m);
        
    if(su<sum)
    for(i=x+1;i<n;i++)
    if(su+a[i]<=sum&&vist[i]==0)
    DFS(i);

    m--;vist[x]=0;su-=a[x];
}
int main()
{
    int i;
    while(scanf("%d%d",&sum,&n)>0&&(sum||n))
    {
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        sort(a,a+n,cmp);//从大到小排序
        flog=0;k=0;m=0;
        memset(vist,0,sizeof(vist));
        memset(len,0,sizeof(len));
        printf("Sums of %d:\n",sum);
        for(i=0;i<n;i++)
        DFS(i);
        if(flog==0)
        printf("NONE\n");
    }
}

抱歉!评论已关闭.