现在的位置: 首页 > 综合 > 正文

hdu2952(DFS Counting Sheep )

2018年02月22日 ⁄ 综合 ⁄ 共 2072字 ⁄ 字号 评论关闭
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things,
I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.

Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also
decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps
A and C are in the same flock.

Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these
programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100

Sample Input
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###

Sample Output
6 3
题目的意思:#代表睡的地方,要找到有多少个孤立的睡觉地方,相连的#看作一个整体。
#include<stdio.h>
int h,w,sum,dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char map[105][105];

void DFS(int i,int j)
{
    int e;
    map[i][j]='.';
    for(e=0;e<4;e++)
    if(i+dir[e][0]>=0&&i+dir[e][0]<h&&j+dir[e][1]>=0&&j+dir[e][1]<w)
    if(map[i+dir[e][0]][j+dir[e][1]]=='#')
    DFS(i+dir[e][0],j+dir[e][1]);
}

int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&h,&w);
        for(i=0;i<h;i++)
        {
            getchar();
            for(j=0;j<w;j++)
            scanf("%c",&map[i][j]);
        }
        sum=0;
        for(i=0;i<h;i++)
        for(j=0;j<w;j++)
        if(map[i][j]=='#')
        {
            sum++;
            DFS(i,j);
        }

        printf("%d\n",sum);
    }
}

抱歉!评论已关闭.