现在的位置: 首页 > 综合 > 正文

Girls’ research 最长回文串

2018年02月22日 ⁄ 综合 ⁄ 共 1588字 ⁄ 字号 评论关闭
Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……,
'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.

Sample Input
b babd a abcd

Sample Output
0 2 aza No solution!
#include<stdio.h>
#include<string.h>
int main()
{
    int e,i,j,h,d,len;
    char ch,str[200005];
    while(scanf("%c %s",&ch,str)==2)
    {
        h=d=0;
        len=strlen(str);
        for(i=0;i<len;i++)
        {
            for(j=i+1,e=i;j<len&&e>=0;j++,e--)
            if(str[e]!=str[j])
            break;
            if(d-h<j-e-2)
            {
                h=e+1;
                d=j-1;
            }
            for(j=i+1,e=i-1;j<len&&e>=0;j++,e--)
            if(str[e]!=str[j])
            break;
            if(d-h<j-e-2)
            {
                h=e+1;d=j-1;
            }
        }

        if(d-h>0)
        {
            printf("%d %d\n",h,d);
            for(i=h;i<=d;i++)
            if(str[i]>=ch)
            printf("%c",str[i]-ch+'a');
            else
            printf("%c",str[i]-ch+1+'z');
            printf("\n");
        }
        else
        printf("No solution!\n");

        getchar();
    }
}

抱歉!评论已关闭.