现在的位置: 首页 > 综合 > 正文

POJ3177Redundant Paths(边的双连通性,用vector时一定要去掉重边)

2018年02月22日 ⁄ 综合 ⁄ 共 2873字 ⁄ 字号 评论关闭
Redundant Paths
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9118   Accepted: 3925

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular
path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only
travel on Official Paths when they move from one field to another. 

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate
routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample: 

One visualization of the paths is: 

   1   2   3
   +---+---+  
       |   |
       |   |
 6 +---+---+ 4
      / 5
     / 
    / 
 7 +

Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 

   1   2   3
   +---+---+  
   :   |   |
   :   |   |
 6 +---+---+ 4
      / 5  :
     /     :
    /      :
 7 + - - - - 

Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
 
Every pair of fields is, in fact, connected by two routes. 

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

Source

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
using namespace std;

vector<int>map[5005];
int low[5005],dfn[5005],stack[5005],sn,deep,k,node[5005],vist[5005];
int MIN(int a,int b){ return a>b?b:a; }
void DFS(int p,int fath)
{
    int u,m;
    stack[++sn]=p; vist[p]=1;
    deep++; low[p]=dfn[p]=deep;
    m=map[p].size();

    for(int j=0;j<m;j++)
    {
        u=map[p][j];
        if(fath==u)continue;
        if(vist[u]==0)
        {
            DFS(u,p);
            low[p]=MIN(low[p],low[u]);
        }
        else if(vist[u]==1)
            low[p]=MIN(low[p],dfn[u]);
    }
    if(low[p]==dfn[p])
    {
        k++;
        while(stack[sn]!=p){
            node[stack[sn]]=k; vist[stack[sn--]]=2;
        }
            node[stack[sn]]=k; vist[stack[sn--]]=2;
    }
}
int answer(int n)
{
    int d[5005]={0},tj;
    sn=deep=k=0;
    DFS(1,-1);
    for(int i=1;i<=n;i++)
    for(int j=0;j<map[i].size();j++)
    {
        tj=map[i][j];
        if(node[i]!=node[tj])
            d[node[i]]++;
    }
    int ans=0;
    for(int i=1;i<=k;i++)
    if(d[i]==1)
    ans++;
    ans++;
    return ans/2;
}
int vv[5005][5005];
int main()
{
    int n,m,a,b;
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i=1;i<=n;i++)
        {
            map[i].clear(); vist[i]=0;
            for(int j=1;j<=n;j++)
            vv[i][j]=0;
        }
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(vv[a][b]==0)//去掉重边,以防在计算度时得出错误答案
            {
                map[a].push_back(b);
                map[b].push_back(a);
                vv[a][b]=vv[b][a]=1;
            }
        }
        printf("%d\n",answer(n));
    }
}

抱歉!评论已关闭.