现在的位置: 首页 > 综合 > 正文

POJ3352Road Construction(边的双连通+强连通缩点)

2018年02月22日 ⁄ 综合 ⁄ 共 3351字 ⁄ 字号 评论关闭
Road Construction
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8673   Accepted: 4330

Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between
the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between
two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist
attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration,
if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions
are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w.
Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

Source

边的双连通定义:在无向图G中,任意两点之间至少有两条路可走,且每条路不经过同一个边。也就是说每个边只属于一条路径。
解题:首先求强连通分量,后缩点,缩点后的图中度为1的点只要度变成2就形成了边的双连通。那么在这些度为1的点中取两个点连起来,重复动作,就能使这些点的度数变成2,所以添加最少的边数=(度为1的点数+1)/2;
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<vector>
using namespace std;
vector<int>map[1005];
int stack[1005],sn,vist[1005],low[1005],dfn[1005],deep,node[1005],k;
int Min(int a,int b)
{
    return a>b?b:a;
}
void dfs(int i,int fath)
{
    vist[i]=1; stack[++sn]=i;
    deep++; low[i]=dfn[i]=deep;
    int len=map[i].size();
    for(int j=0;j<len;j++)
    {
        int tj=map[i][j];
        if(tj==fath)continue;
        if(vist[tj]==0)
        {
            dfs(tj,i);
            low[i]=Min(low[i],low[tj]);
        }
        else if(vist[tj]==1)
            low[i]=Min(low[i],dfn[tj]);
    }
    if(low[i]==dfn[i])
    {
        k++;
        while(stack[sn]!=i)
        {
            node[stack[sn]]=k; vist[stack[sn--]]=2;
        }
         node[stack[sn]]=k; vist[stack[sn--]]=2;
    }
}
int answer(int n)
{
    k=0; deep=0; sn=0;
    for(int i=1;i<=n;i++)
        vist[i]=0;
    int ans=0,in[1005]={0};
        dfs(1,-1);

    for(int i=1;i<=n;i++)//缩点
    for(int j=0;j<map[i].size();j++)
    {
        int tj=map[i][j];
        if(node[i]!=node[tj])
            in[node[i]]++;
    }
    for(int i=1;i<=k;i++)
    if(in[i]==1)
     ans++;
    if(ans%2==1) ans++;
    return ans/2;//双连通,度为1的点两两相连添加边
}
int main()
{
    int n,m,a,b;
    while(scanf("%d%d",&n,&m)>0)
    {
        for(int i=1;i<=n;i++)
        map[i].clear();
        while(m--)
        {
            scanf("%d%d",&a,&b);
            map[a].push_back(b);
            map[b].push_back(a);
        }
        printf("%d\n",answer(n));
    }
}

抱歉!评论已关闭.