现在的位置: 首页 > 综合 > 正文

hdu149850 years, 50 colors (多个最小顶点覆盖)

2018年02月22日 ⁄ 综合 ⁄ 共 2267字 ⁄ 字号 评论关闭

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1516 Accepted Submission(s): 818

Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing
color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind
of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students
are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.


Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of
n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".

Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0

Sample Output
-1 1 2 1 2 3 4 5 -1

题意:在校庆活动当中,有n*n个格子,里面放有不同颜色的汽球,让学生去拍汽球,但一次只能拍一行或一列的相同颜色的汽球,并且一个学生最多只能拍k次,问那些颜色的汽球不能在4k次中拍完则输出汽球的颜色,按升序排列,如果没有则输出-1.

解题:看起来无从下手,可是根据题意可知,我们可以把不同颜色的汽球分开来,对每种汽球各求一次,这样就是一个最小顶覆盖问题了。

#include<stdio.h>
#include<string.h>
int map[55][105][105],vist[105],match[105],n;
int find(int i,int c)
{
    for(int j=1;j<=n;j++)
    if(!vist[j]&&map[c][i][j])
    {
        vist[j]=1;
        if(match[j]==0||find(match[j],c))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int m,c,cc[55];
    while(scanf("%d%d",&n,&m)>0&&n+m!=0)
    {
        memset(map,0,sizeof(map));
        memset(cc,0,sizeof(cc));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&c); map[c][i][j]=1; cc[c]=1;
        }
        int flag=0,ans;
        for(int c=1;c<=50;c++)
        if(cc[c])
        {
            ans=0; memset(match,0,sizeof(match));
            for(int i=1;i<=n;i++)
            {
                memset(vist,0,sizeof(vist));
                ans+=find(i,c);
            }
            if(ans>m)
            {
               if(flag)printf(" "); printf("%d",c); flag=1;
            }
        }
        if(flag==0)printf("-1");
        printf("\n");
    }
}

抱歉!评论已关闭.