现在的位置: 首页 > 综合 > 正文

hdu2119Matrix (二分匹配,最小顶点覆盖)

2018年02月22日 ⁄ 综合 ⁄ 共 1230字 ⁄ 字号 评论关闭

Matrix

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1819 Accepted Submission(s): 792

Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

Sample Input
3 3 0 0 0 1 0 1 0 1 0 0

Sample Output
2

Author
Wendell
#include<stdio.h>
#include<string.h>
int map[105][105],vist[105],match[105],m;
int find(int i)
{
    for(int j=1;j<=m;j++)
    if(!vist[j]&&map[i][j])
    {
        vist[j]=1;
        if(!match[j]||find(match[j]))
        {
            match[j]=i; return 1;
        }
    }
    return 0;
}
int main()
{
    int a,n;
    while(scanf("%d",&n)>0&&n)
    {
        scanf("%d",&m);
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&a);
            if(a) map[i][j]=1;
        }
        int ans=0;
        memset(match,0,sizeof(match));
        for(int i=1;i<=n;i++)
        {
            memset(vist,0,sizeof(vist));
            ans+=find(i);
        }
        printf("%d\n",ans);
    }
}

抱歉!评论已关闭.