现在的位置: 首页 > 综合 > 正文

hdu3033I love sneakers! (分组背包,错了很多次)

2018年02月22日 ⁄ 综合 ⁄ 共 2148字 ⁄ 字号 评论关闭
Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.


There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania,he desires to buy at least
one product for each brand.

Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector,he
won’t buy the same product twice.

Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following
N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66

Sample Output
255
题目意思:用M钱去卖东西,有k个品牌,要求:1.用M钱必须满足能买到k种品牌,每种品牌至少一样。2每样东西只买一个。
#include<stdio.h>
#define inf -0x7fffffff
struct nn
{
    int k,v[105],u[105];
}T[15];
int M,dp[15][10005];
int max(int a,int b,int c)
{
    if(a<b)a=b;
    if(a<c)a=c;
    return a;
}
void fenzupack(int t)
{
    for(int e=1;e<=T[t].k;e++)
    {
        int w,use;
        w=T[t].v[e]; use=T[t].u[e];
        for(int m=M;m>=use;m--)
        {
            dp[t][m]=max(dp[t][m],dp[t-1][m-use]+w,dp[t][m-use]+w);//关建
        }
    }
}
int main()
{
    int n,K,ty,use,w,m;
    while(scanf("%d%d%d",&n,&M,&K)==3)
    {
        for(int j=0;j<=M;j++) dp[0][j]=0;
        for(int i=1;i<=K;i++)
        {
            T[i].k=0;
            for(int J=0;J<=M;J++)
                dp[i][J]=inf;
        }
        while(n--)
        {
            scanf("%d%d%d",&ty,&use,&w);
            T[ty].k++; m=T[ty].k;
            T[ty].u[m]=use;
            T[ty].v[m]=w;
        }
        for(int t=1;t<=K;t++)
        {
            fenzupack(t);
        }
        if(dp[K][M]>=0)
        printf("%d\n",dp[K][M]);
        else
        printf("Impossible\n");
    }
}
/*
5  50 3
1 20 30
2 30 500
3 20 60
2 10 10
3 40 10

3 5 3
1 6 0
2 0 0
3 0 0

3 5 3
1 0 5
2 0 1
3 0 2

3 5 3
1 0 0
2 0 0
3 0 0

5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66

100
Impossible
8
0
255
*/

抱歉!评论已关闭.