现在的位置: 首页 > 综合 > 正文

hdu1712ACboy needs your help(分组背包)

2018年02月22日 ⁄ 综合 ⁄ 共 1071字 ⁄ 字号 评论关闭
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the
profit?

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0

Sample Output
3 4 6
题意:有n个课程,现在花M天来学习这些课程,学习每个课程花的天数所得到的价值不同,求M天怎么分配学习才能得到的价值最大。输入时是一个n*M的矩阵A[i][j]。
#include<stdio.h>
int a[105][105],dp[105],M;
void fenzupack(int i)
{
    for(int m=M;m>0;m--)
        for(int j=1;j<=m;j++)
        if(dp[m]<dp[m-j]+a[i][j])
        dp[m]=dp[m-j]+a[i][j];
}
int main()
{
    int n;
    while(scanf("%d%d",&n,&M)>0&&n+M!=0)
    {
        for(int i=1;i<=n;i++)
        for(int j=1;j<=M;j++)
        scanf("%d",&a[i][j]);
        for(int j=0;j<=M;j++) dp[j]=0;
        for(int i=1;i<=n;i++)
        fenzupack(i);
        printf("%d\n",dp[M]);
    }
}

抱歉!评论已关闭.