现在的位置: 首页 > 综合 > 正文

hdu1266(Reverse Number)

2018年02月22日 ⁄ 综合 ⁄ 共 1165字 ⁄ 字号 评论关闭
Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.

Output
For each test case, you should output its reverse number, one case per line.

Sample Input
3 12 -12 1200

Sample Output
21 -21 2100
 
#include<stdio.h>
#include<string.h>
int main()
{
    int t,i,j,len,k;
    char a[1000];
    while(scanf("%d",&t)==1&&t)
    {
        while(t--)
        {
            getchar();
            scanf("%s",a);
            k=j=0;len=strlen(a);
            if(a[0]=='-')
            {
                j=1;
            }
            for(i=len-1;i>=j;i--)
            if(a[i]=='0')
            k++;
            else
            break;
            
            if(j==1&&i!=j-1)
            printf("-");
            if(i!=j-1)
            {
                for(i=i;i>=j;i--)
                printf("%c",a[i]);
                for(i=1;i<=k;i++)
                printf("0");
            }
            else
            printf("0");

            printf("\n");
        }
    }
}

抱歉!评论已关闭.