现在的位置: 首页 > 综合 > 正文

dfs 著名的油田分块的问题

2018年04月15日 ⁄ 综合 ⁄ 共 1912字 ⁄ 字号 评论关闭
Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 


Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following
this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 


Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 


Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 


Sample Output
0 1 2 2
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int m,n;

struct node
{
    int x,y,ans;
};

char mapp[101][101];
int visit[101][101];
int dir[8][2] = {{0,1},{1,1},{1,0},{-1,0},{0,-1},{-1,-1},{-1,1},{1,-1}};

void dfs(int x,int y)
{
    int i;
    for(i = 0; i<8; i++)
    {
        int tx = x+dir[i][0];
        int ty = y+dir[i][1];
        if(tx<m && tx>=0 && ty>=0 && ty<n && !visit[tx][ty] && mapp[x][y]=='@' )//顺序是个严重的问题。。
        {
            visit[tx][ty] = 1;
            dfs(tx,ty);
        }
    }
}
int main()
{
    int i,j;
    int countt = 0;
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        if(m==0&&n==0)break;
        countt = 0;
        memset(visit,0,sizeof(visit));
        for(i = 0; i<m; i++)
        {
            scanf("%s",&mapp[i]);
        }
        for(i = 0; i<m; i++)
        {
            for(j = 0; j<n; j++)
            {
                if(mapp[i][j]=='@' && !visit[i][j])
                {
                    visit[i][j] = 1;
                    dfs(i,j);
                    countt++;
                }
            }
        }
        printf("%d\n",countt);

    }
    return 0;
}
//终于明白了。。请允许我做一个感动的表情==、

抱歉!评论已关闭.