现在的位置: 首页 > 综合 > 正文

POJ-1258 最小生成树 prim算法

2018年04月15日 ⁄ 综合 ⁄ 共 2122字 ⁄ 字号 评论关闭
prim(假设图是连通的,转化成连通网的最小生成树)
n个顶点----全部连通----n-1条路
mapp记录所有边
dis 记录权值
vis 标记是否经过
搜索最小边
把最小边加进去
累加到ans里
最后记得更新权值
Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39435   Accepted: 15987

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines
of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

最小生成树的模板题,不是很难,但是小循环的循环变量跟大循环用成一个了。。
改了好久才发现这里错了。。而且,坐标的下标标错了。好桑心。。


#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f3f

using namespace std;

int mapp[505][505];
int dis[5050];
int vis[5050];
int ans,flag;
int prim(int m)
{
    int i,j;
    int pos;
    int minn;
    memset(vis,0,sizeof(vis));
    // memset(dis,0,sizeof(dis));
    ans = 0;
    for(i=1; i<=m; i++)
    {
        dis[i] = mapp[1][i];
    }
    vis[1] = 1;
    for(i=1; i<=m-1; i++)
    {
        minn = INF;
        for(j=1; j<=m; j++)
        {
            if(vis[j]==0&&minn>dis[j])
            {
                pos = j;
                minn = dis[j];
            }
        }
        vis[pos] = 1;
        ans = ans + minn;
        if(minn>=INF)
        {
            break;
        }
        for(j=1; j<=m; j++)
        {
            if(vis[j]==0&&dis[j]>mapp[pos][j])
            {
                dis[j] = mapp[pos][j];
            }
        }
    }
    return ans;
}


int main()
{
    int n;
    int a;
    int t;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&a);
                mapp[i][j] = a;
                mapp[j][i] = a;
            }
        }
        t = prim(n);
        printf("%d\n",t);
    }
    return 0;
}

抱歉!评论已关闭.