现在的位置: 首页 > 综合 > 正文

10361 – Automatic Poetry

2018年04月23日 ⁄ 综合 ⁄ 共 2707字 ⁄ 字号 评论关闭
文章目录

UVa OJ

Root :: AOAPC
I: Beginning Algorithm Contests (Rujia Liu)
 :: Volume
1. Elementary Problem Solving
 :: String

Problem I

Automatic Poetry

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

 

“Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

 

In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual,
the riddle is not very intellectually challenging.

 

This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

 

Ein Kind halt seinen Schnabel nur,

wenn es hangt an der Nabelschnur.        

 

/*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

 

A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that,
and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

s1<s2>s3<s4>s5

 

where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is
the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

Sample Input

3

ein kind haelt seinen <schn>abel <n>ur

wenn es haengt an der ...

weil wir zu spaet zur <>oma <k>amen

verpassten wir das ...

<d>u <b>ist

...

Sample Output

ein kind haelt seinen schnabel nur

wenn es haengt an der nabel schnur

weil wir zu spaet zur oma kamen

verpassten wir das koma amen

du bist

bu dist

题目比较简单,首先是把第一段中的“<" 或”>"删去。 然后将第二段中的“...'换成尖括号里面的内容

通过几个标记量来记录一下尖括号的位置,相对比较方便。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctype.h>
using namespace std;
int main ()
{
    int t;
    cin>>t;
    getchar();
    while (t--)
    {
        char l1[120],l2[120];
        int biaoji[4][2];
        gets(l1);
        gets(l2);
        int len=strlen(l1),i=0,j=0;
        for (i=0; i<len; i++)
        {
            if (l1[i]!='<' && l1[i]!='>') cout<<l1[i];
            if (l1[i]=='<') biaoji[0][j]=i;
            if (l1[i]=='>') biaoji[1][j++]=i;
        }
        cout<<endl;
        int len2=strlen(l2);
        i=0;
        while(l2[i]!='.')
        {
            cout<<l2[i];
            i++;
        }
        for (i=biaoji[0][1]+1; i<biaoji[1][1]; i++)
            cout<<l1[i];
        for (i=biaoji[1][0]+1; i<biaoji[0][1]; i++)
            cout<<l1[i];
        for (i=biaoji[0][0]+1; i<biaoji[1][0]; i++)
            cout<<l1[i];
        for (i=biaoji[1][1]+1; i<len; i++)
            cout<<l1[i];
        cout<<endl;

    }
    return 0;
}

抱歉!评论已关闭.