现在的位置: 首页 > 综合 > 正文

10010 – Where’s Waldorf?

2018年04月23日 ⁄ 综合 ⁄ 共 3162字 ⁄ 字号 评论关闭

UVa OJ


 Where's Waldorf? 

Given a m by n grid
of letters, ( 
$1 \leq m,n \leq 20$),
and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be
treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank
line between two consecutive inputs.

The input begins with a pair of integers, m followed by n$1 \leqm,n \leq 50$ in
decimal notation on a single line. The next m lines contain n letters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another
integer k appears on a line by itself ( $1 \leq k \leq 20$). The next k lines of input contain the list of words to search
for, one word per line. These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line
in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found
(1 represents the leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e.
the occurence which places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.

Sample Input

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert

Sample Output

2 5
2 3
1 2
7 8

从二维字符数组当中找到给出的单词,忽略大小写。

而找的方式可以为上下左右,四个对角线八个方向。

输出位于最上方,且最左方的首字符的位置

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<ctype.h>
using namespace std;
int visited[55][55];
int direct[8][2]={1,0,-1,0,0,1,0,-1,1,1,1,-1,-1,1,-1,-1};
int t,n,m,k,i,j,len,p;
char map[55][55],word[55];
struct node
{
    int x;
    int y;
};
int inside(int x, int y)
{
    if (x>=0 && x<m && y>=0 && y<n) return 1;
    return 0;
}
int fi(int x,int y)
{
    int i,j,t=0,k;
    len=strlen(word);
    for (k=0; k<8; k++)
    {
        int xx=x,yy=y;
        for (i=1; i<len; i++)
        {
            xx+=direct[k][0];
            yy+=direct[k][1];
            if (inside(xx,yy)==0 || map[xx][yy]!=word[i])
            {
                t++;
                break;
            }
        }
        if (i==len) return 1;
    }
    return 0;
}
int main ()
{
    cin>>t;
    while (t--)
    {
        cin>>m>>n;
        memset(map,0,sizeof(map));
        for (i=0; i<m; i++)
            for (j=0; j<n; j++)
            {
                cin>>map[i][j];
                if (map[i][j]>='a') map[i][j]-=32;
            }
/*        for (i=0; i<m; i++)
        {
            for (j=0; j<n; j++)
                cout<<map[i][j];
            cout<<endl;
        }
*/
        cin>>k;
        while (k--)
        {
            cin>>word;
            len=strlen(word);
            for (i=0; i<len; i++)
                if (word[i]>='a') word[i]-=32;
//            cout<<word<<endl;
            p=0;
            for (i=0; i<m; i++)
            {
                for (j=0; j<n; j++)
                {
                    if (word[0]==map[i][j])
                        p=fi(i,j);
                    if (p) break;
                }
                if (p) break;
            }
            cout<<i+1<<" "<<j+1<<endl;
        }
        if (t>=1) cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.