现在的位置: 首页 > 综合 > 正文

HDOJ–2602–Bone Collector【背包问题】

2018年04月24日 ⁄ 综合 ⁄ 共 1454字 ⁄ 字号 评论关闭
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

 


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 


Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 


Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 


Sample Output
14
 


Author
Teddy
 


Source
 


Recommend
lcy
 

思路:01背包问题

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n,v,t,i,j,value[1005],volume[1005],dp[1005];
    scanf("%d",&t);
    while(t--)
    {
        memset(value,0,sizeof(value));
        memset(volume,0,sizeof(volume));
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++)
            scanf("%d",&value[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&volume[i]);
        for(i=1;i<=n;i++)
            for(j=v;j>=volume[i];j--)
                if(dp[j]<dp[j-volume[i]]+value[i])
                    dp[j]=dp[j-volume[i]]+value[i];
        printf("%d\n",dp[v]);
    }
    return 0;
}

抱歉!评论已关闭.