现在的位置: 首页 > 综合 > 正文

HDOJ–1711–Number Sequence【KMP】

2018年04月24日 ⁄ 综合 ⁄ 共 1524字 ⁄ 字号 评论关闭
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.
 


Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N].
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 


Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 


Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 


Sample Output
6 -1
 


Source
 


Recommend
lcy
 

思路:字符串匹配,可以用KMP来做,为了方便没有定义char数组,用的是int数组,但是思路一样。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
using namespace std;
int nxt[10005];
int a[10000005],b[10005];
int n,m;
void get_nxt(int *pat,int lenp)
{
    int i = 0, j = -1;
    nxt[0] = -1;
    while(i < lenp)
    {
        if(j == -1 || pat[i] == pat[j])
        {
            i ++;
            j ++;
            if(pat[i]!=pat[j])
                nxt[i] = j;
            else
                nxt[i]=nxt[j];
        }
        else
            j = nxt[j];
    }
}
int KMP(int *text,int *pat)
{
    int lent = n,lenp = m;
    get_nxt(pat,lenp);
    int i = 0, j = 0;
    while(i < lent && j < lenp)
    {
        if(j == -1 || text[i] == pat[j])
       {
           i ++;
           j ++;
        }
        else
            j = nxt[j];
     }
     if(j >= lenp) return i - lenp+1;
     else return -1;
}
int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<m;i++)
            scanf("%d",&b[i]);
        printf("%d\n",KMP(a,b));
    }
    return 0;
}

抱歉!评论已关闭.