现在的位置: 首页 > 综合 > 正文

HDOJ–1856–More is better【并查集】

2018年04月24日 ⁄ 综合 ⁄ 共 1955字 ⁄ 字号 评论关闭

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory
Limit: 327680/102400 K (Java/Others)

Total Submission(s): 8985    Accepted Submission(s): 3354


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 


Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 


Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 


Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 


Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 


Author
lxlcrystal@TJU
 


Source
 


Recommend
lcy
 


思路:并查集简单题,注意因为每个数的father不一定是最高的祖先,不能依据最多的相同的最高祖先来判定结果,再定义一个member,来记录每个的子孙数,再选出最高的即可。

#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<time.h>
using namespace std;
int father[10000005],member[10000005],n;
int find(int x)
{
    if(father[x]!=x) father[x]=find(father[x]);
    return father[x];
}
void combine(int a,int b)
{
    int x,y;
     x = find( a );
     y = find( b );
     if( x!=y )
     {
         father[y] = x;
         member[x] += member[y];
     }
}
int main()
{
    int i,x,y,ma,mi;
    while(scanf("%d",&n)!=EOF)
    {
        ma=0;
        mi=1;
        for(i=0;i<=10000000;i++)
        {
            father[i]=i;
            member[i]=1;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            if(x>mi||y>mi)
                mi=max(x,y);
            combine(x,y);
        }
        for(i=1;i<=mi;i++)
        {
            if(member[i]>ma)
                ma=member[i];
        }
        printf("%d\n",ma);
    }
    return 0;
}

抱歉!评论已关闭.