现在的位置: 首页 > 综合 > 正文

HDOJ–2199–Can you solve this equation?【二分法】

2018年04月24日 ⁄ 综合 ⁄ 共 1071字 ⁄ 字号 评论关闭
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 


Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 


Sample Input
2 100 -4
 


Sample Output
1.6152 No solution!
 


Author
Redow
 


Recommend
lcy
 

思路:简单的二分法求解。

#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;

int b=0;

int f(double x1,double x2,double y)
{
    double f,f1,f2,x;
    f1=8*x1*x1*x1*x1 + 7*x1*x1*x1 + 2*x1*x1 + 3*x1 + 6 - y ;
    f2=8*x2*x2*x2*x2 + 7*x2*x2*x2 + 2*x2*x2 + 3*x2 + 6 - y ;
    if(f1*f2>0)
    {
        b=1;
        return 0 ;
    }
    do
    {
        x=(x1+x2)/2;
        f=8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6 - y ;
        if(f*f1>0)
        {
            x1=x;
            f1=f;
        }
        else if(f*f2>0)
        {
            x2=x;
            f2=f;
        }
    }while(fabs(f)>1e-6);
    printf("%.4lf\n",x);
    return x;
}

int main()
{
    int n;
    double y,l,t,x;
    scanf("%d",&n);
    while(n--)
    {
        l=0;
        t=100;
        scanf("%lf",&y);
        x=f(l,t,y);
        if(b==1)
            printf("No solution!\n");
    }
    return 0;
}

抱歉!评论已关闭.