现在的位置: 首页 > 综合 > 正文

POJ2352树状数组

2018年04月25日 ⁄ 综合 ⁄ 共 2013字 ⁄ 字号 评论关闭

拿到这道题以及开始做的过程中,突然明白,树状数组的基础我还没弄明白,对诸位初学者说一声,一定要将理论弄明白,否则真的很坑

题意:给出一些星星的坐标,求出每个等级的星星有多少个(星星的等级等于它左下角的星星数之和。

解题思路:典型的树状数组问题,由题意可知Y是升序输入,故我们只操作坐标X,对X而言,因为第一个星星的坐标可以从0开始,故在更新树状数组的时候,要先++x;然后由getsum()函数求出等级,++veal[sum]完成每个等级星星数的统计

函数update是将出现过星星的地方加1,刷新整个树状结构

函数getsum是得到一个区间和,在本题中,这个区间和就是星星的等级数

B - Stars

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d
& %I64u

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

现给出AC代码

#include<cstdio>
#include<string.h>
using namespace std;
const int MAX = 32000+10;
int c[MAX];
int veal[MAX];
int M,N,X,Y;

int lowbit(int i)
{
    return i & (-i);
}
void updata(int x)
{
    while(x < MAX)
    {
        ++c[x];
        x += lowbit(x);
    }
}
int getsum(int x)
{
    int ans = 0;
    while(x > 0)
    {
        ans += c[x];
        x -= lowbit(x);
    }
    return ans;
}

int main()
{
    int sum;
   scanf("%d",&N);
   M = N;
   memset(c,0,sizeof(0));
   memset(veal,0,sizeof(0));
  while(N--)
   {
        scanf("%d%d",&X,&Y);
       ++X;
       updata(X);
       sum = getsum(X);
        ++veal[sum];
   }
   for(int i = 1; i <=  M; i++)
   {
       printf("%d\n",veal[i]);
   }
}

抱歉!评论已关闭.