现在的位置: 首页 > 综合 > 正文

【DP(背包)】 hdu2955 Robberies

2018年04月25日 ⁄ 综合 ⁄ 共 1872字 ⁄ 字号 评论关闭

Robberies

http://acm.hdu.edu.cn/showproblem.php?pid=2955



Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 


Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 


Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 


Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 


Sample Output
2 4 6

01背包。

#include<cstdio>
#include<cstring>
using namespace std;
#define max(a,b) ((a)>(b)?(a):(b))
double dp[10005];
int num[105];
double p[105];
int main()
{
    int T,n,summ;
    double P;
    scanf("%d",&T);
    for(;T--;)
    {
        scanf("%lf%d",&P,&n);
        summ=0;
        for(int i=1;i<=n;++i)
        {
            scanf("%d%lf",&num[i],&p[i]);
            //被抓概率转化为逃走概率
            p[i]=1-p[i];
            summ+=num[i];
        }
        //初始化
        for(int i=0;i<=summ;++i) dp[i]=0;
        //没抢劫的时候逃跑概率为1
        dp[0]=1;
        for(int i=1;i<=n;++i)
            for(int j=summ;j>=num[i];--j)
                   dp[j]=max(dp[j],dp[j-num[i]]*p[i]);
        int ans=0;
        for(int i=summ;i>=0;--i)
            if(dp[i]>1-P)
            {
                ans=i;
                break;
            }
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.