现在的位置: 首页 > 综合 > 正文

hdu 2425 Hiking Trip

2018年04月26日 ⁄ 综合 ⁄ 共 3040字 ⁄ 字号 评论关闭

BFS水题

Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the
path that will bring him to the destination with the least amount of time. Can you help him?

You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or
path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.

Given Green's current position and his destination, please determine the best path for him. 
 
Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, VP,
VS, VT (1 <= VP <= 100, 1 <= VS <= 100, 1 <=
VT <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly C characters,
each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, SR, SC, TR,
TC, (0 <= SR < R, 0 <= SC < C, 0 <= TR < R, 0
<= TC < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.

There is a blank line after each test case. Input ends with End-of-File.
 
Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 
SampleInput
4 6
1 2 10
T...TT
TTT###
TT.@#T
..###@
0 1 3 0

4 6
1 2 2
T...TT
TTT###
TT.@#T
..###@
0 1 3 0

2 2
5 1 3
T@
@.
0 0 1 1
 
SampleOutput
Case 1: 14
Case 2: 8
Case 3: -1
 

 

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define data 100000000
char map[21][21];
int mark[21][21];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int sx,sy,ex,ey,treetime,pathtime,sandtime,totaltime;
int n,m;
struct node
{
    int x,y,time;
}nodes[21];
int overmap(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m) return 1;
    else return 0;
}
int bfs()
{
    int lsum;
    queue<node>q;
    node first,next;
    first.x=sx;
    first.y=sy;
    first.time=0;
    mark[first.x][first.y]=0;
    q.push(first);
    while(!q.empty())
    {
        first=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            next.x=first.x+dir[i][0];
            next.y=first.y+dir[i][1];
            if(!overmap(next.x,next.y)&&map[next.x][next.y]!='@')
            {
              if(map[next.x][next.y]=='T')
              {
               next.time=first.time+treetime;
              }
              if(map[next.x][next.y]=='.')
              {
                next.time=first.time+sandtime;
              }
              if(map[next.x][next.y]=='#')
              {
                next.time=first.time+pathtime;
              }
              if(next.time<mark[next.x][next.y])
              {
                mark[next.x][next.y]=next.time;
                q.push(next);
              }
            }
        }
    }
    return mark[ex][ey];
}
int main()
{
    int flag=0;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        flag++;
        scanf("%d%d%d",&pathtime,&sandtime,&treetime);
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
        }
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        mark[i][j]=data;
        scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
        printf("Case %d: ",flag);
        if(bfs()<data) printf("%d\n",bfs());
        else printf("-1\n");
    }
    return 0;
}

 

抱歉!评论已关闭.