现在的位置: 首页 > 综合 > 正文

UVA 340 Master-Mind Hints

2018年04月28日 ⁄ 综合 ⁄ 共 3210字 ⁄ 字号 评论关闭

Description

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of
a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code tex2html_wrap_inline35 and a guess tex2html_wrap_inline37 ,
and are to determine the hint. A hint consists of a pair of numbers determined as follows.

match is a pair (i,j), tex2html_wrap_inline41 and tex2html_wrap_inline43 ,
such that tex2html_wrap_inline45 . Match (i,j) is called strong when i = j, and is called weak otherwise.
Two matches (i,j) and (p,q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the
number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.

 

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the
range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would
normally be specified). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated
by a comma. The entire list of hints for each game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0

Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)

题目大意:

就是说有一串code,然后一个人说出一串数字,和这个code进行匹配,如果在a[i] == b[j]且i==j的情况下,我们就给A++,如果a[i]==b[j]且i!=j的情况下,我们就给B++,

最后在每一次猜测的结束,输出(A,B).

解题思路:

哎,不多说了,在VJ上挂了小白书的所有习题练习,励志完成大部分吧,,不能说所有了,从现在开始一道一道的开始切吧,静下心来慢慢的学吧。。

这是一道有关排序和检索的题目,没什么难度,就是模拟下这个过程就好了,由于一开始没有说范围,导致我RE了2次,搜题解,,才看到数组都是1000+,,于是开了个2333

的数组玩,,这道题目应该注意的就是两个要点,一个要点是我们先将满足A条件的情况筛选出来,然后将a[i]=b[j]=0,这一步的操作是很重要的,然后,在对于B类的情况进行筛选,注意输入和输出的格式就好了。。

代码:

# include<cstdio>
# include<iostream>

using namespace std;

# define MAX 2333

int a1[MAX];//code的备份
int a[MAX];//code本身
int b[MAX];//break

int main(void)
{
    int n;
    int A,B;
    int icase = 1;
    while ( cin>>n )
    {
        if ( n==0 )
            break;
        for ( int i = 0;i < n;i++ )
        {
            cin>>a[i];
            a1[i] = a[i];
        }
        printf("Game %d:\n",icase++);

        int flag = 1;

        while ( flag )
        {
            int sum = 0;
            for ( int i = 0;i < n;i++ )
            {
                cin>>b[i];
                if ( b[i]==0 )
                {
                    sum++;
                }
            }
            if ( sum==n )
            {
                break;
            }


            A = 0;
            B = 0;

            for ( int i = 0;i < n;i++ )
            {
                if ( a[i]==b[i] )
                {
                    A++;
                    a[i] = b[i] = 0;
                }
            }

            for ( int i = 0;i < n;i++ )
            {
                for ( int j = 0;j < n;j++ )
                {
                    if ( a[i]==b[j]&&b[j]!=0&&a[i]!=0 )
                    {
                        B++;
                        a[i] = b[j] = 0;
                    }
                }
            }

            printf("    (%d,%d)\n",A,B);


            for ( int i = 0;i < n;i++ )
            {
                a[i] = a1[i];
            }



        }
    }


    return 0;
}

抱歉!评论已关闭.