现在的位置: 首页 > 综合 > 正文

POJ 3069 Saruman’s Army

2018年04月29日 ⁄ 综合 ⁄ 共 1993字 ⁄ 字号 评论关闭
Saruman's Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4364   Accepted: 2249

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

解题思路:
裸裸的贪心,先对于输入点的坐标进行排序,然后从最左边的点开始,选择的依据是距离该点为R的范围内的最远的那个点了。
然后标记这个点,然后从这个被标记的点开始,再以R为距离,选出离该点距离+R最近的一个点(这个点要在+R的外部),将这个点标记后,依次类推,直到N个点都扫完为止。
代码:
    # include<cstdio>
    # include<iostream>
    # include<algorithm>

    using namespace std;

    # define MAX 1234

    int X[MAX];
    int R,N;

    int main(void)
    {
          while ( cin>>R>>N )
          {
              if ( R==-1&&N==-1 )
                {
                    break;
                }

                for ( int i = 0;i <= N-1;i++ )
                    {
                        cin>>X[i];
                    }
                sort(X,X+N);
                int j = 0;
                int ans = 0;
                while ( j < N )
                    {
                        int s = X[j++];
                        while ( j < N&&X[j]<=s+R )
                            {
                                j++;
                            }
                        int p = X[j-1];

                        while ( j < N&&X[j]<=p+R )
                            {
                                j++;
                            }
                        ans++;
                    }
                    cout<<ans<<endl;

          }



        return 0;
    }

抱歉!评论已关闭.