现在的位置: 首页 > 综合 > 正文

POJ Saruman’s Army 3069

2018年05月02日 ⁄ 综合 ⁄ 共 2006字 ⁄ 字号 评论关闭
Saruman's Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4520   Accepted: 2329

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positionsx1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

这道题大意:在一条直线上有N个点。点位置是xi,从N个点中选若干个进行标记,对于每一个点,其距离为R以内的区域内必须有一个标记的点,满足这个条件下,最少标记几个点?
#include<stdio.h>
#include<algorithm>
using namespace std;
int N,x[1010],R;
int solve ()
{
	int l=0,i=0,count=0;
	sort(x,x+N);
	while(i<N){
		int l=x[i++];//l是最左端未标记的点。
		while(i<N&&x[i]<=l+R)i++;//找到需要标记的点。
		int p=x[i-1];//p就是最新加标记的点。
		while(i<N&&x[i]<=p+R)i++;//一直向右前进直到距p距离大于R的点。
		count++;
	}
	return count;
}
int main()
{
	int solve();
	while(scanf("%d%d",&R,&N),R!=-1&&N!=-1){
		for(int i=0;i<N;i++)
		scanf("%d",&x[i]);
		int num=solve();
		printf("%d\n",num);
	}
	return 0;
 } 

抱歉!评论已关闭.