现在的位置: 首页 > 综合 > 正文

POJ Best Cow Line 3617

2018年05月02日 ⁄ 综合 ⁄ 共 2023字 ⁄ 字号 评论关闭
Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11321   Accepted: 3347

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source

本题大意就是:给定一个长度为N的字符串S,然后构造一个长度为N的字符串T。起初T是空串,然后反复进行下列操作:
①从S头部删除一个字符,加到T尾部;
②从S尾部删除一个字符,加到T尾部。
目标是构造一个字典序尽可能小的字符串T。
本题主要利用贪心思想,主要算法实现如下:
不断取S开头结尾中较小的一个放到T尾部。
但需要考虑特殊情况就是当头尾元素相同时,我们就要比较下一个字符大小。
#include<stdio.h>
char cow[2010];
int N;
void solve()
{
	bool left=false;
	int a=0,b=N-1,x=0;
	while(a<=b){
	  for(int i=0;a+i<=b;i++){
	  	if(cow[a+i]>cow[b-i]){
	  		left=true;
	  		break;
		  }
		else if(cow[a+i]<cow[b-i]){
			left=false;
			break;
		}
	  }
	  
	  if(x==80){
	  	printf("\n");x=0;
	  }
	  if(left)putchar(cow[b--]);
	  else putchar(cow[a++]);
	  x++;	
	}
	return;
}
int main()
{
	void solve();
	while(~scanf("%d",&N)){
		getchar();
		for(int i=0;i<N;i++){
		scanf("%c",&cow[i]);
		getchar();			
		}
		solve();
		printf("\n");
	}
	return 0;
 } 

注意题目要求格式,80个换行~输入时是一个字母占一行。


抱歉!评论已关闭.