现在的位置: 首页 > 综合 > 正文

POJ Lake Counting 2386(DFS)

2018年05月02日 ⁄ 综合 ⁄ 共 1689字 ⁄ 字号 评论关闭
Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21594   Accepted: 10873

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

题目大致思路就是替换W周围所有W。。
从任意的W开始,不停地把邻接的部分用'.'代替。1次DFS后与初始的这个W连接的所有W就都被替换成了'.',因此直到图中不再存在W为止,总共进行DFS的次数就是答案了。8个方向共对应了8种状态转移,每个格子作为DFS的参数至多被调用一次,所以复杂度为O(8×N×M)=O(N×M)。
#include<stdio.h>
char f[100][101];
int N,M;
void dfs(int x,int y)
{
	f[x][y]='.';
	int dx,dy;
	for(dx=-1;dx<=1;dx++){
	 for(dy=-1;dy<=1;dy++){
	   int nx=x+dx,ny=y+dy;
	   if(nx>=0&&nx<N&&ny>=0&&ny<M&&f[nx][ny]=='W')dfs(nx,ny);	 	
	 }
    }
   return;
}
int main()
{
	void dfs(int x,int y);
//	freopen("C:\\Users\\兆豫\\Desktop\\acm.txt","r",stdin);
	while(scanf("%d%d",&N,&M)!=EOF){
		int i,j,count=0;
		for(i=0;i<N;i++)
//		 for(j=0;j<M;j++)
		  scanf("%s",f[i]);//无语,开始一直找不到错误,原来题目要求输入每行之间没有空格。
	    for(i=0;i<N;i++){
	     for(j=0;j<M;j++){
	     	if(f[i][j]=='W'){
				dfs(i,j);
				count++;
			 }
       	 }
        }
       	 printf("%d\n",count);
	}
	return 0;
}

抱歉!评论已关闭.