现在的位置: 首页 > 综合 > 正文

HDU 1673 Optimal Parking

2018年05月02日 ⁄ 综合 ⁄ 共 1204字 ⁄ 字号 评论关闭

Optimal Parking

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1918    Accepted Submission(s): 1605

Problem Description
When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs.
Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?
Long Street is a straight line, where all positions are integer.
You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.
Input
The first line of input gives the number of test cases, 1 <= t <= 100. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1 <= n <= 20, and the second gives their n integer positions
on Long Street, 0 <= xi <= 99.
Output
Output for each test case a line with the minimal distance Michael must walk given optimal parking.
Sample Input
2 4 24 13 89 37 6 7 30 41 14 39 42
Sample Output
152 70
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 105
int a[N];
int main()
{
	int t,i,n;
//	freopen("text.txt","r",stdin);
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		printf("%d\n",(a[n-1]-a[0])*2);
		
	}
	return 0;
} 

抱歉!评论已关闭.