现在的位置: 首页 > 综合 > 正文

HDU 1256 画8

2018年05月02日 ⁄ 综合 ⁄ 共 1235字 ⁄ 字号 评论关闭

画8

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4645    Accepted Submission(s): 2004

Problem Description
谁画8画的好,画的快,今后就发的快,学业发达,事业发达,祝大家发,发,发.
Input
输入的第一行为一个整数N,表示后面有N组数据.
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度.
Output
画横线总是一个字符粗,竖线随着总高度每增长6而增加1个字符宽.当总高度从5增加到6时,其竖线宽度从1增长到2.下圈高度不小于上圈高度,但应尽量接近上圈高度,且下圈的内径呈正方形.
每画一个"8"应空一行,但最前和最后都无空行.
Sample Input
2 A 7 B 8
Sample Output
AA AA AA AA AA AA AA AA AA AA AA BBB BB BB BB BB BBB BB BB BB BB BB BB BBB
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int t,d,height_wid,height_hei,temp,i,j;
	char ch[2];
//	freopen("text.txt","r",stdin);
	scanf("%d",&t); 
	while(t--)
	{
		scanf("%s%d",&ch,&d); 
//		printf("%d\n",d);
		height_wid=d/6+1;//ÏÂÃæµÄ¿í 
		temp=d-3;
		height_hei=(temp%2==0?temp/2:temp/2+1);//ÏÂÃæµÄ¸ß 
		temp=temp/2;//ÉÏÃæµÄ 
		for(i=1;i<=d;i++)
		{
			if(i==1||i==d||i==2+temp)
			{
				for(j=1;j<=height_wid;j++)
					printf(" ");
				for(j=1;j<=height_hei;j++)
					printf("%c",ch[0]);
				printf("\n");
			}
			else if(i<2+temp)
			{
				for(j=1;j<=height_wid;j++)
					printf("%c",ch[0]);
				for(j=1;j<=height_hei;j++)
					printf(" ");
				for(j=1;j<=height_wid;j++)
					printf("%c",ch[0]);
				printf("\n");
			}
			else
			{
				for(j=1;j<=height_wid;j++)
					printf("%c",ch[0]);
				for(j=1;j<=height_hei;j++)
					printf(" ");
				for(j=1;j<=height_wid;j++)
					printf("%c",ch[0]);
				printf("\n");
			}	
		}
		
		if(t!=0)
			printf("\n");
	}
	return 0;
} 

抱歉!评论已关闭.