现在的位置: 首页 > 综合 > 正文

HDOJ 3038 How Many Answers Are Wrong 并查集

2018年05月02日 ⁄ 综合 ⁄ 共 2642字 ⁄ 字号 评论关闭

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2616    Accepted Submission(s): 1012

Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).



Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo
this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the
answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why
asking trouble for himself~~Bad boy)

 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
1
/*
并查集的题,用sum[i]记录1到i的和,
则输入的时候左端点a, 跟右端点b,就可以看作是两个独立的数据
sum[a], sum[b]表示 1到a, 1到b的和。

父节点相同,即dis[b]-dis[a]不等于c,次数加1.

注意:节点小的作为父节点放前面。
  
*/
#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;

#define MAX 200005
int pre[MAX],dis[MAX];

int find(int x)
{    
    int t; 
    if(x==pre[x]) return x;
    
    t=pre[x];
    pre[x]=find(pre[x]);
    dis[x]+=dis[t];//回溯的过程中计算dis[x]到根的大小
    return pre[x];
}

int main()
{
    int i,n,m,sum,f1,f2,a,b,s;
    
//    freopen("test.txt","r",stdin);
    
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<=n;i++)
            pre[i]=i;
                
        memset(dis,0,sizeof(dis));
        sum=0;
        
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&s);
            a--;
            f1=find(a);
            f2=find(b);
            
            if(f1==f2)
            {
                if(dis[b]-dis[a]!=s)//和不同 
                    sum++;
            }
            else
            {
                dis[f2]=dis[a]+s-dis[b];//更新f2的值  
                pre[f2]=f1;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

抱歉!评论已关闭.