现在的位置: 首页 > 综合 > 正文

HDOJ 3047 Zjnu Stadium 并查集

2018年05月02日 ⁄ 综合 ⁄ 共 2089字 ⁄ 字号 评论关闭

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1660    Accepted Submission(s): 624

Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns
were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered
B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests
and count them as R.
 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output
For every case:
Output R, represents the number of incorrect request.
 

Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output
2
Hint
Hint: (PS: the 5th and 10th requests are incorrect)
/*
hdoj 3047 带权并查集 
相同的位置重复 就是incorrect 
*/

#include<iostream>
#include<stdio.h>
using namespace std;
#define MAX 50001

int pre[MAX],dis[MAX];
int find(int x)
{
    int t;
    if(x==pre[x]) return x;
    t=find(pre[x]);
    dis[x]=(dis[x]+dis[pre[x]])%300;
    pre[x]=t;
    return t;
} 

void Union(int a,int b,int c)
{
    pre[b]=a;
    dis[b]=c;    
}

int main(){
    
    int n,m,i,sum,a,b,c,t1,t2,temp;
//    freopen("test.txt","r",stdin);
    
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            pre[i]=i;
            dis[i]=0;
        }
        
        sum=0;
        while(m--)
        {
            scanf("%d%d%d",&a,&b,&c);
            t1=find(a);
            t2=find(b);
            if(t1==t2)
            {
                temp=dis[b]-dis[a];//两者相对距离:b到根节点距离 减去a到根节点距离 
                if(temp<0) temp+=300;
                if(temp!=c) sum++; //相对距离不等与C 表示与当前的不符合 错误 
            }
            else
            {
                temp=dis[a]+c-dis[b];
                temp%=300;
                if(temp<0) temp+=300;
                Union(t1,t2,temp);//ab已经find了 
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

抱歉!评论已关闭.