现在的位置: 首页 > 综合 > 正文

HDU 1016 Prime Ring Problem 【DFS】

2018年05月02日 ⁄ 综合 ⁄ 共 1348字 ⁄ 字号 评论关闭

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27775    Accepted Submission(s): 12342

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input
6 8
 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

/*题解:
    第一个自己用DFS解决的搜索问题,一次AC,但感觉对搜索仍然不是很懂。 
*/

#include<cstdio>
int a[22],vis[22],n;
int prime[12]={2,3,5,7,11,13,17,19,23,29,31,37};

int is_prime(int x)
{
    for(int i=2; i*i<=x; i++)
        if(x%i==0)
            return 0;
    return 1;
}

void dfs(int pos)
{
    if(pos==n&&a[0]==1&&is_prime(a[0]+a[n-1]))
    {
        printf("%d",a[0]);
        for(int i=1; i<n; i++)
            printf(" %d",a[i]);
        printf("\n");
        return;
    } 
    for(int i=1; i<=n; i++)
    {
        if(vis[i]&&is_prime(a[pos-1]+i))
        {
            vis[i]=0;
            a[pos]=i;
            dfs(pos+1);
            vis[i]=1;
        }
    }
}     
        
    
int main()
{
    int k;
    k=1;
    while(scanf("%d",&n)!=EOF)
    {
        printf("Case %d:\n",k++); 
        for(int i=1; i<=n; i++)
            vis[i]=1;
        a[0]=1; 
        dfs(0);
        printf("\n");
    }
    return 0;
} 

 

抱歉!评论已关闭.