现在的位置: 首页 > 综合 > 正文

hdu 1021 Fibonacci Again

2018年05月02日 ⁄ 综合 ⁄ 共 789字 ⁄ 字号 评论关闭

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36549    Accepted Submission(s): 17648

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no no
/*     应用求模公式         (1) (a + b) % p = (a % p + b % p) % p         (2) (a - b) % p = (a % p - b % p) % p         (3) (a * b) % p = (a % p * b % p) % p         (4) a ^ b % p = ((a % p)^b) % p         先打表防止超时     */
#include<stdio.h>
int a[1000000]={7,11,0};   
int main()
{
    int i,n;
    for(i=2;i<1000000;i++)
    {
        a[i]=(a[i-1]%3+a[i-2]%3)%3;   //(a+b)%3=(a%3+b%3)%3 
    }                        
    while(scanf("%d",&n)!=EOF)
    {
        if(a[n]%3==0)
        printf("yes\n");
        else
        printf("no\n");
    }
    return 0;
}
        

抱歉!评论已关闭.