现在的位置: 首页 > 综合 > 正文

hdu 1213 How Many Tables

2018年05月02日 ⁄ 综合 ⁄ 共 1630字 ⁄ 字号 评论关闭

hdu 1213 How Many Tables
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13272    Accepted Submission(s): 6490

Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
 

Sample Output
2
4
 
/*题解:
    考察并查集,雷同畅通公路,最后求合并后的集合个数,详解请见: 

        http://blog.csdn.net/u013806814/article/details/38376559

    */

#include<cstdio>
int pre[1010];
int find(int x)
{
    if(x==pre[x]) return x;
    else pre[x]=find(pre[x]);
    return pre[x];
}
int join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
    }
}
int main()
{
    int T,n,m,i,sum,a,b;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&n,&m);
        for(i=1; i<=n; i++)
        pre[i]=i;
        for(i=0; i<m; i++)
        {
            scanf("%d %d",&a,&b);
            join(a,b);
        }
        for(i=1,sum=0; i<=n; i++)
        {
            if(pre[i]==i)
            sum++;
        }
        printf("%d\n",sum);
       if(T!=0) getchar();    //这格式真新奇,有点反人类啊 
    }
   // while(1);
    return 0;
}
    

抱歉!评论已关闭.