现在的位置: 首页 > 综合 > 正文

hdu 1023 Train Problem II

2018年05月02日 ⁄ 综合 ⁄ 共 1706字 ⁄ 字号 评论关闭

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5945    Accepted Submission(s): 3236

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 

Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 

Sample Input
1 2 3 10
 

Sample Output
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
 

/*题解:
Catalan数应用中的凸多边形三角划分问题,直接将Catalan数输出即可 
*/

Catalan模板:
void catalan()
{
    int i,j,len,carry,temp;
    a[1][0] = b[1] = 1;
    len = 1;
    for(i=2; i<=100; i++)
    {
        for(j=0; j<len; j++)
        a[i][j] = a[i-1][j]*(4*(i-1)+2);
        carry = 0;
        for(j=0; j<len; j++)
        {
            temp = a[i][j]+carry;
            a[i][j] = temp%10;
            carry = temp/10;
        }
        while(carry)
        {
            a[i][len++] = carry%10;
            carry/=10;
        }
        carry = 0;
        for(j=len-1; j>=0; j--)
        {
            temp = carry*10+a[i][j];
            a[i][j]=temp/(i+1);
            carry=temp%(i+1);
        }
        while(!a[i][len-1])
        len--;
        b[i] = len;
    }
}

AC代码:

#include<cstdio>
int a[102][102],b[102];
void catalan()
{
    int i,j,len,carry,temp;
    a[1][0] = b[1] = 1;
    len = 1;
    for(i=2; i<=100; i++)
    {
        for(j=0; j<len; j++)
        a[i][j] = a[i-1][j]*(4*(i-1)+2);
        carry = 0;
        for(j=0; j<len; j++)
        {
            temp = a[i][j]+carry;
            a[i][j] = temp%10;
            carry = temp/10;
        }
        while(carry)
        {
            a[i][len++] = carry%10;
            carry/=10;
        }
        carry = 0;
        for(j=len-1; j>=0; j--)
        {
            temp = carry*10+a[i][j];
            a[i][j]=temp/(i+1);
            carry=temp%(i+1);
        }
        while(!a[i][len-1])
        len--;
        b[i] = len;
    }
}

int main()
{
	int i,n;
	catalan();
	while(scanf("%d",&n)!=EOF)
	{
		for(i=b[n]-1; i>=0; i--)
			printf("%d",a[n][i]);
		printf("\n");
	}
	return 0;
}

同样题目还有

Game of Connections

http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1002&cid=24946

这是Catalan应用中的出栈次序问题

抱歉!评论已关闭.