现在的位置: 首页 > 算法 > 正文

poj1058 Humble Numbers

2018年12月21日 算法 ⁄ 共 1893字 ⁄ 字号 评论关闭

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13129    Accepted Submission(s): 5705


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

 


Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 


Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 


Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 


Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

分析:

f[i] = min{f[m]*2, f[k]*3, f[p]*5,f[j]*7}

m,k,p,j为小于i的某个下标。

如果min = f[m]*2 ,则令f[i] = f[m]*2, m = m+1。

....

...

计算下一个丑数。

code:

#include <stdio.h>
#include <string.h>
#define INF 0xfffffff
const int maxn =6000;
int f[maxn];

int min(int a, int b, int c, int d)
{
    if(a>b) a = b;
    if(a>c) a = c;
    if(a>d) a = d;
    return a;
}
void init()
{
    int i, x1, x2, x3, x4, num1, num2, num3, num4;
    f[1] = 1;
    x1 = x2 = x3 = x4 = 1;
    for(i=2; i<=maxn; i++)
    {
        num1 = 2*f[x1];
        num2 = 3*f[x2];
        num3 = 5*f[x3];
        num4 = 7*f[x4];
        f[i] = min(num1, num2, num3, num4);
        if(f[i]==num1) x1++;
        if(f[i]==num2) x2++;
        if(f[i]==num3) x3++;
        if(f[i]==num4) x4++;
    }
}

int main()
{
    int n;
    init();
    while(scanf("%d",&n),n)
    {
        if(n%10==1&&n%100!=11)
            printf("The %dst humble number is %d.\n",n,f[n]);
        else if(n%10==2&&n%100!=12)
            printf("The %dnd humble number is %d.\n",n,f[n]);
        else if(n%10==3&&n%100!=13)
            printf("The %drd humble number is %d.\n",n,f[n]);
        else
            printf("The %dth humble number is %d.\n",n,f[n]);
    }
    return 0;
}


抱歉!评论已关闭.