现在的位置: 首页 > 算法 > 正文

poj2192 | HDU1501 – Zipper(最长公共子序列)

2018年12月21日 算法 ⁄ 共 2296字 ⁄ 字号 评论关闭

                                                                                                                                      Zipper

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14117   Accepted: 4958

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

Source

思路:设dp[i][j]表示s1[0..i-1] 和 s2[0..j-1]能否组合成s3[0..i+j-1]。是 dp[i][j] = 1; 否 dp[i][j] = 0;
           状态转移:
                     if
                        i>0 && s3[i+j-1] == s[i-1] && dp[i-1][j]  
                     or
                       j>0  && s3[i+j-1] == s[j-1] && dp[i][j-1]
                     then 
                         dp[i][j] = 1
                     else 
                         dp[i][j] = 0
#include <stdio.h>
#include <string.h>
char s1[201],s2[201],s3[402];
int dp[201][201];
int len1, len2, len3;
int main()
{
    int n, k=0, i, j;
    scanf("%d",&n);
    while(k++<n)
    {
        printf("Data set %d: ",k);
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        scanf("%s %s %s",s1,s2,s3);
        len1 = strlen(s1);
        len2 = strlen(s2);
        len3 = strlen(s3);
        if(len3 != len1 + len2)
        {
            printf("no\n");
            continue;
        }
        for(i=0; i<=len1; ++i)
            for(j=0; j<=len2; ++j)
            {
                if(i>0 && s3[i+j-1]==s1[i-1] && dp[i-1][j])
                    dp[i][j] = 1;
                if(j>0 && s3[i+j-1]==s2[j-1] && dp[i][j-1])
                    dp[i][j] = 1;
            }
        if(dp[len1][len2]) printf("yes\n");
        else printf("no\n");
    }
    return 0;
}

抱歉!评论已关闭.