现在的位置: 首页 > 综合 > 正文

UVA 562 Dividing coins

2018年12月22日 ⁄ 综合 ⁄ 共 1832字 ⁄ 字号 评论关闭

  Dividing coins 


It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched
the coin to great length and thus created copper-wire.

Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should
favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...

That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.

Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to
split a single coin.

Input 

A line with the number of problems n, followed by n times:

  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of n lines. Each line contains the minimal positive difference between the amount
the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1

题意: 一对金币,要求你把它分成两堆,并算出它们的最小差值。

分析:01背包,只要把总金币额的一半作为背包即可。

#include <stdio.h>
#include <string.h>

int a[105];
int f[25005];

int main()
{
     int n, m, i,j, T, sum;
     scanf("%d",&T);
     while(T--) {
          scanf("%d",&n);
          sum = 0;
          for(i=0; i<n; i++) {
               scanf("%d",&a[i]);
               sum += a[i];
          }
          m = sum>>1;
         memset(f,0,sizeof(f));
          f[0] = 1;
          for(i=0; i<n; i++)
               for(j=m; j>=a[i]; j--)
                    f[j] = f[j] || f[j-a[i]];
          for(i=m; i>=0; i--)
               if(f[i]) break;
          printf("%d\n",sum - 2*i);
     }
     return 0;
}

抱歉!评论已关闭.