现在的位置: 首页 > 算法 > 正文

poj1976 A Mini Locomotive

2018年12月22日 算法 ⁄ 共 2771字 ⁄ 字号 评论关闭
A Mini Locomotive
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 2115   Accepted: 1173

Description

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive
can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported
by the three mini locomotives. 

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the ith number of in this
line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger
coaches. 

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1
7
35 40 50 10 30 45 60
2

Sample Output

240

题目:http://poj.org/problem?id=1976

分析:好题,强力推荐!

设f[i][j]表示前i个车厢,用j个车头拉的最多能拉多少人。

则f[i][j] = max{f[i-1][j], f[k][j-1] + a[i] - a[k]}  , k = max(i-m,0)


#include <stdio.h>
#include <string.h>
#define max(a,b) ((a)>(b)?(a):(b))
int f[50005][4], a[50005];

int main()
{
    int t, n, i, j, k, m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1,a[0]=0; i<=n; i++) scanf("%d",&a[i]), a[i] +=a[i-1];
        scanf("%d",&m);
        memset(f,0,sizeof(f));
        for(i=1; i<=n; i++)
        for(j=1; j<4; j++)
        {
            k = i-m;
            if(k<0) k = 0;
            f[i][j] = max(f[i-1][j], f[k][j-1] + a[i]-a[k]);
        }
        printf("%d\n",f[n][3]);
    }
    return 0;
}

抱歉!评论已关闭.