现在的位置: 首页 > 算法 > 正文

poj1745 Divisibility

2018年12月22日 算法 ⁄ 共 1594字 ⁄ 字号 评论关闭
Divisibility
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9483   Accepted: 3302

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are
eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible
by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

 

分析: 好题!!

f[i][j]表示前i个数经过加减能否达到模k余数为j这个状态。

 

code:

#include <stdio.h>
#include <string.h>
#define get(x) ((x)<0?(-(x))%(k): (x)%(k))
int a[11115];
int f[2][115];

int main()
{
     int n, k, i, j;
     int bit= 0;
     while(~scanf("%d%d",&n, &k)) {
          for(i=0; i<n; i++) scanf("%d",&a[i]);
          for(i=0; i<k; i++) f[0][i] = 0;
          f[0][get(a[0])] = 1;
          for(i=1; i<n; i++) {
               bit =i&1;
               for(j=0; j<k; j++) f[bit][j] = 0;
               for(j=0; j<k; j++)
                    if(f[!bit][j])
                         f[bit][get(j-a[i])] = f[bit][get(j+a[i])] = 1;
          }
          if(f[bit][0])
               printf("Divisible\n");
          else
               printf("Not divisible\n");
     }
     return 0;
}

 

 

抱歉!评论已关闭.