现在的位置: 首页 > 综合 > 正文

hdu1423—Greatest Common Increasing Subsequence

2019年02月14日 ⁄ 综合 ⁄ 共 1832字 ⁄ 字号 评论关闭

Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output
output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1 5 1 4 2 5 -12 4 -12 1 2 4

Sample Output

2

Source
ACM暑期集训队练习赛(二)

Recommend
lcy | We have carefully selected several similar problems for you: 1422 1400 1418 1424 1401

求最长公共上升子序列

设dp[i][j] 表示a的前i个数和b的前j个数,以b[j]结尾的LCIS长度
如果a[i] != b[j]
令dp[i][j] = dp[i - 1][j]; //即取上一次的最优解
如果a[i] == b[j]
那么dp[i][j] = max (dp[i - 1][k]) + 1;
加以优化,复杂度可以控制在O(m*n)

/*************************************************************************
    > File Name: hdu1423.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月21日 星期六 19时12分48秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 510;
int dp[N][N];
int a[N];
int b[N];

int main ()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        int n, m;
        scanf("%d", &n);
        for (int i = 1; i <= n; ++i)
        {
            scanf("%d", &a[i]);
        }
        scanf("%d", &m);
        for (int i = 1; i <= m; ++i)
        {
            scanf("%d", &b[i]);
        }
        memset (dp, 0, sizeof(dp));
        for (int i = 1; i <= n; ++i)
        {
            int maxs = 0;
            for (int j = 1; j <= m; ++j)
            {
                dp[i][j] = dp[i - 1][j];
                if (a[i] > b[j] && maxs < dp[i][j])
                {
                    maxs = dp[i][j];
                }
                if (a[i] == b[j])
                {
                    dp[i][j] = maxs + 1;
                }
            }
        }
        int ans = 0;
        for (int i = 1; i <= m; ++i)
        {
            ans = max (dp[n][i], ans);
        }
        printf("%d\n", ans);
        if (t)
        {
            printf("\n");
        }
    }
    return 0;
}

抱歉!评论已关闭.