现在的位置: 首页 > 综合 > 正文

hdu1059—Dividing

2019年02月14日 ⁄ 综合 ⁄ 共 3086字 ⁄ 字号 评论关闭

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.

The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output
For each colletcion, output Collection #k:'', where k is the number of the test case, and then eitherCan be divided.” or “Can’t be divided.”.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0

Sample Output

Collection #1: Can’t be divided. Collection #2: Can be divided.

Source
Mid-Central European Regional Contest 1999

发现水不过,然后用了二进制优化的多重背包

/*************************************************************************
    > File Name: hdu1059.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年02月21日 星期六 14时24分04秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

//const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 2000010;
int dp[N];
int num[10];
int v;

void zero_one (int cost, int val)
{
    for (int i = v; i >= cost; --i)
    {
        if (dp[i - cost] + val > dp[i])
        {
            dp[i] = dp[i - cost] + val;
        }
    }
}

void complete (int cost, int val)
{
    for (int i = cost; i <= v; ++i)
    {
        if (dp[i - cost] + val > dp[i])
        {
            dp[i] = dp[i - cost] + val;
        }
    }
}

void duochon (int ret, int cost, int val)
{
    int k = 1;
    if (ret * cost >= v)
    {
        complete (cost, val);
    }
    while (k < ret)
    {
        zero_one (k * cost, k * val);
        ret -= k;
        k <<= 1;
    }
    zero_one (ret * cost, ret * val);
}

int main ()
{
    int icase = 1;
    while (~scanf("%d%d%d%d%d%d", &num[1], &num[2], &num[3], &num[4], &num[5], &num[6]))
    {
        if (!num[1] && !num[2] && !num[3] && !num[4] && !num[5] && !num[6])
        {
            break;
        }
        memset (dp, -inf, sizeof(dp));
        printf("Collection #%d:\n", icase++);
        v = num[1] + 2 * num[2] + 3 * num[3] + 4 * num[4] + 5 * num[5] + 6 * num[6];
        if (v & 1)
        {
            printf("Can't be divided.\n");
            printf("\n");
            continue;
        }
        dp[0] = 0;
        v /= 2;
        for (int i = 1; i <= 6; ++i)
        {
            if (num[i] == 1)
            {
                zero_one (i, i);
                continue;
            }
            duochon (num[i], i, i);
        }
        if (dp[v] == v)
        {
            printf("Can be divided.\n");
        }
        else
        {
            printf("Can't be divided.\n");
        }
        printf("\n");
    }
    return 0;
}

抱歉!评论已关闭.